0
Not a bug

PHP Fatal error: Class 'Google_Config' not found

xsmthx 3 years ago updated by Антон 2 years ago 3

Добрый день! Скачал по инструкции с помощью composer google/apiclient и adata/apiclient. Получил вышеуказанную ошибку. Поправил версию google/apiclient - не помогло. Что делать?


Вот кусок из compser.json:

"require": {
"dadata/apiclient": "^1.0",
"google/apiclient": ">= 1.1.7"
}

Кстати, в файле dadata/apiclient/src/Dadata/Client.php ошибка в методе execute: интерфейс требует, чтобы он выглядет так и только так:


public function execute(\Psr\Http\Message\RequestInterface $request, $expectedClass = NULL)

вместо execute($request)

Answer

Answer
Under review

Да, разработчику уже поставили баг по этой проблеме, но он, к сожалению, не исправил. Попробуйте пока версию без гугл-клиента: https://gist.github.com/nalgeon/091d172ae316ad6b66eb6f6f94575639

Answer
Under review

Да, разработчику уже поставили баг по этой проблеме, но он, к сожалению, не исправил. Попробуйте пока версию без гугл-клиента: https://gist.github.com/nalgeon/091d172ae316ad6b66eb6f6f94575639

Разобрался, можно закрывать. Неправильно понял последний комментарий тут . Версия должна быть четко 1.1.7